[X2Go-User] problem getting x2go to work.

Michael DePaulo mikedep333 at gmail.com
Mon Jun 30 05:18:06 CEST 2014

See responses inline.

On Sun, Jun 29, 2014 at 10:35 PM, Jon Gilbert <jjj at prismnet.com> wrote:
> Mike-
> I finally noticed in my client that when I killed the x2gostartagent process, if the client is still open when I issue the kill command, then a window appears in the client this message over and over:
> Connection failed <my_username> is not authorized at /usr/lib/x2go/x2gosqlitewrapper.pl line 526.
> The client really ought to show these kinds of errors without you having to kill the process on the server. But there is a bug in the Mac client where you cannot check the "show details" button until *after* a successful login. Therefore you never get to see the verbose output when your logins fail -- which is when it would be most useful to see it!

Is there an existing bug report for this behavior of the Mac client?
If not, please report it. Instructions:

> Anyway after some digging on that error message, I figured out that my problem was that my Bitnami AMI had me signing in as username "ubuntu" which is really just an alias to the user "bitnami". But because I was signed in as a different username than the name of the home folder, it was messing up. When I logged instead using "bitnami" as the username, then suddenly it worked... kind of.

OK. I think I this should be documented on the wiki as under a page
like "known issues with virtual appliances." Or "common configuration
issues." I'll take care of that. I want to see if there is an existing
page 1st. Thank you for documenting it via this email.

> gnome-session --session=gnome-fallback does not work for me... I'd see the screen but was not able to click on anything. I thought, maybe I have the wrong bindings installed, so I tried to aptitude install x2gognomebindings but it just kept saying this error:
> Couldn't find any package matching "x2gognomebindings".  However, the following
> packages contain "x2gognomebindings" in their description:
>   x2goserver-fmbindings
> So then I installed the x2goserver-fmbindings and I still couldn't get it to respond. I could see the desktop but nothing happens if I click.
> I could also not get on with just using the GNOME selection.

See comment below about UNITY.

> I did have better luck with gnome-session --session=gnome-classic but it's still unusably slow. Even on 32k JPEG and with bandwidth set to WAN, stuff just happens way too slow, or doesn't happen at all. I know it's not my connection that's the problem. It's probably because it's an Amazon Micro instance, and it's just dog slow.
> If I use xfce4, I wonder if it would run faster? I'd like to try your xfce4 steps but I've already installed ubuntu-desktop, so will it hurt me to also install xfce4 alongside it? Can I have both installed? I just want to know if I should start over fresh with a new AMI. I don't need anything fancy, just want a GUI for managing files and running basic utilities like a git client.

OK, I think I see the problem. "ubuntu-desktop". You have the UNITY
desktop environment installed, not vanilla GNOME. Please try
specifying "UNITY" as your session type. Our logic in the "x2goserver"
package will make sure Unity runs in Unity 2d mode. This mode is
provided by package "unity-2d". "ubuntu-desktop" depends on
"unity-2d", so you do have "unity-2d" installed.

Also, as for XFCE:

It's lightweight and it never tries to use 3d effects, so it runs
faster to one degree or another.

I recommend installing it according to my instructions.

Absolutely, you can have both desktop environments installed. If you
had a physical machine, you would select which desktop environment to
use at the display manager's greeter (the graphical login screen.)

> Thanks,
> Jon

No Problem,

> On Sat. 28 Jun.2014, at 7:29 AM, Michael DePaulo <mikedep333 at gmail.com> wrote:
>> Hi Jon,
>> Sorry to hear that you are running into this problem.
>> On Mon, Jun 23, 2014 at 10:13 PM, Jon Gilbert <jjj at prismnet.com> wrote:
>>> I have a server set up which is Ubuntu 12.04.4 LTS (GNU/Linux 3.2.0-64-virtual x86_64).
>>> I installed ubuntu-desktop as instructed by the x2go wiki. I also did these steps:
>>> sudo apt-get install x2goserver
>>> sudo apt-get install x2goserver-xsession
>>> sudo apt-get install sqlite3
>>> sudo x2godbadmin --createdb
>> The last 2 commands should not be necessary. I am not very familiar
>> with the db though.
>>> I try to connect from the Mac client (tried all the versions) and it always fails. It just hangs at the screen where it's trying to connect. I set the server log level to debug and it just says:
>>> Jun 24 00:52:50 <my_ip> /usr/bin/x2golistsessions[32234]: x2golistsessions has been called with no option
>>> Jun 24 00:52:50 <my_ip> /usr/bin/x2gostartagent: x2gostartagent called with options: 800x600 isdn 256k-jpeg unix-kde-depth_32 us query 0 D gnome-flashback.sh
>>> Jun 24 00:52:50 <my_ip> /usr/bin/x2gostartagent: client announced itself as ,,''
>>> Jun 24 00:52:50 <my_ip> /usr/bin/x2gosessionlimit[32271]: x2gosessionlimit has been called
>>> Jun 24 00:52:50 <my_ip> /usr/bin/x2golistsessions[32274]: x2golistsessions has been called with options: --all-servers
>>> Jun 24 00:52:51 <my_ip> /usr/lib/x2go/x2gogetdisplays[32289]: db_getdisplays called, server: <my_ip>; return value:
>>> Jun 24 00:52:51 <my_ip> /usr/lib/x2go/x2gogetports[32298]: db_getports called, server: <my_ip>; return value:
>>> Jun 24 00:52:52 <my_ip> /usr/lib/x2go/x2gogetdisplays[32342]: db_getdisplays called, server: <my_ip>; return value:
>>> Jun 24 00:52:52 <my_ip> /usr/lib/x2go/x2gogetports[32351]: db_getports called, server: <my_ip>; return value:
>>> It repeats this over and over as the processor runs at 100% on the server, being hosed by the several x2go processes that seem to be stuck in an infinite loop.
>>> You'll notice that it runs gnome-flashback.sh in my command, that's because it doesn't work to connect the normal way either, so I tried the steps outlined in this e-mail from this list:
>>> http://lists.x2go.org/pipermail/x2go-user/2014-May/002260.html
>> There is no need to follow those steps because you are using Ubuntu
>> 12.04.4, not Ubuntu 14.04. Ubuntu 12.04 has GNOME 3.2, not GNOME 3.8.
>> GNOME 3.6 and earlier have gnome "fallback" session, which is
>> compatible with X2Go. "flashback" isn't even available until GNOME
>> 3.8, it's what "fallback" was renamed to.
>>> (I find it annoying that it doesn't work with Gnome 3 according to that e-mail, yet it doesn't mention this incompatibility in a conspicuous way anywhere on the x2go site.)
>> 1st, to fix your issue, I think you merely need to install package
>> gnome-session-fallback.
>> 2nd, I agree that our wiki should have a page on distro &
>> desktop-environment compatibility. I need to discuss how to design it
>> though. Once I create it (or someone else creates it), it should be
>> referenced/linked to from other instructions pages on the wiki.
>> 3rd, MIke#1 plans to create meta-packages that depend on the necessary
>> packages per DE. This will make it easier for users to recognize that
>> they need to install certain packages, and easier to install them.
>>> Anyway I followed all the steps 1. through 6. in the above-linked e-mail, to no avail, because it did nothing at all towards making this work.
>>> BTW my server is on EC2. Don't know if that matters. And yes, I have
>> I have gotten xubuntu 12.04.x to work on EC2 successfully:
>> https://vpsboard.com/topic/4241-running-a-lightweight-gui-on-your-vps-via-x2go/
>> Let's hope GNOME3 (3.2 of course) works well on it too. I look forward
>> to hearing how it performs.
>>> Please let me know what is going wrong here and what I can do to fix this. Thanks. BTW I do have the latest version of XQuartz installed as my client, and I did set it up to accept remote connections and all that. The connection gets made no problem; the problem definitely seems to be on the server.
>>> Jon
>> I'm mostly certain that the aforementioned fix,
>> gnome-session-fallback, is all that is required.
>> Maybe other packages are required. For example, icons are missing on
>> xfce apps unless you install "xubuntu-icon-theme".
>> -Mike#2
> _______________________________________________
> x2go-user mailing list
> x2go-user at lists.x2go.org
> http://lists.x2go.org/listinfo/x2go-user

More information about the x2go-user mailing list