[X2go-Dev] Fedora issues

Robin Green greenrd at greenrd.org
Mon Jun 27 01:37:08 CEST 2011


I struggled mightily to get the git versions of x2goclient and
x2goserver to work on two Fedora 15 machines today, and finally
succeeded. Along the way I ran into a bunch of problems - here are some
that I remember:

1. Out of date or missing information on the wiki - known problem,
and I guess I can help with this at least.

2. The way the nxcomp Makefile installs symbolic links causes a subtle
"permission denied" problem if SELinux is enforcing. The "install"
command installs libraries with the correct SELinux context; the "cp -a"
command does not install symbolic links with the correct context. (I do
not know whether rpmbuild automatically fixes such problems; if it does,
then this would only be a problem for installs from tarballs.)

3. For some reason (I could not figure out why), the
automatically-generated password was not inserted into the file
~/.x2go/sqlpass. That file was empty. I worked around this by manually
resetting the password to another random password and putting the
password in that file.

4. In x2gostartagent, X2GO_LIB does not seem to be set anywhere. So I
added a line to set it.

5. The Makefile of nxcomp installs the libraries into /usr/local/lib,
not /usr/lib/x2go, by default. So I added /usr/local/lib to
LD_LIBRARY_PATH in x2gostartagent.

6. This is not an x2go bug, but Fedora has a very annoying problem that
xauth keeps printing the message:
xauth: /home/greenrd/.Xauthority not writable, changes will be ignored
I do not know what causes this, or what its significance is. I
workaround it by doing: rm ~/.Xauthority*

7. It is necessary to set the hostname in /etc/hosts, or xauth will
complain that the display is invalid. Strangely, the Fedora installation
CD neglects to do this!

8. At least one key, the left arrow key, doesn't work if you tell
x2goclient to keep the same keyboard layout - I had to tell it my
keyboard layout.

Robin Green

More information about the x2go-dev mailing list