[X2Go-Dev] Bug#1200: Environment variables not set

Mihai Moldovan ionic at ionic.de
Fri Aug 11 05:29:13 CEST 2017

Control: reassign -1 x2goserver

First of all, x2goserver actually is the correct stable release. are the current nightly releases.

I personally don't care much about what version is tested, but knowing whether
there's a difference in behavior between the stable and nightly versions is
certainly helpful.

On 08/10/2017 12:24 PM, Bruno CAPELETO wrote:
> Package: <x2goserver> Version: <>
> # uname -a Linux mtcie1 4.9.0-3-amd64 #1 SMP Debian 4.9.30-2+deb9u1
> (2017-06-18) x86_64 GNU/Linux
> The below bugs are most probably related to each other, that's why I open
> one case for all of them.
> The issues are the following : I want to use the French software Laurux,
> which is based on Gambas interpreter, via a x2go session running on a Debian
> 9 server running LXDE (same issues seen on an Ubuntu server, x2goserver
> version =
> As a prerequisite, the software is installed on the server and runs well on
> a local session.
> 1. Whatever the client (Windows or Linux, the local environment 
> variables are not set properly and the software - which needs French 
> localization - crashes. That could be "solved" the following way : 
> /etc/x2go/Xsession :
> ... LANG=fr LC_ALL=fr_FR.UTF-8 export LANG export LC_ALL ...
> That seems to be a revival of older bugs, but it is definitely still here.

How exactly did you set the locale?

The "Debian way" would be to run dpkg-reconfigure locales as root and select the
desired locale(s) to generate and then select the default one.

/etc/environment should not contain any locale settings.

LANGUAGES and especially LC_ALL should normally not be set. LANGUAGES is a
GNU-only list of fallback locales. LANG is the preferred way to set the locale,
since it's being used if all of the LC_* env variables are empty.
"dpkg-reconfigure locales" will do the right thing™.

> 2. At the start of a new session, one gets a windows with an error message
> "No session for pid ..." ; that bug has already been reported several times
> in x2go bug tracking and marked as solved. Actually it is not on my brand new
> system.

What session are you starting exactly? I cannot find the string "No session for
pid" in x2goserver's source code. Not sure what to do with this.

> 3. The single application mode does not work with some of the applications, 
> including that Laurux / Gambas. For example it works with /usr/bin/leafpad,
> but /usr/bin/libreoffice makes the x2go session crash.

That's certainly possible. The most likely cause, as Uli explained, is that the
command daemonizes itself right after launching it. This leads to the X2Go
scripts assuming that the program exited and subsequently also terminating the
session. We've seen such behavior every now and then and worked around it.

However, it looks like x2goagent is crashing when you start libreoffice in your
case. That shouldn't happen. My gut feeling is that this might be another GTK3

I could try to reproduce this in a clean stretch VM.

> 4. The mouse double clic does not work in a x2go session, but only - within
> the Gambas software (works well for example when launching an application)
> and only - when the x2go client is running in a Windows environment (no
> problem when client in a Linux environment)

That sounds like Gambas is doing something funny, though. As far as I was able
to gather, Gambas seems to be using Qt5 as its drawing toolkit.

The package qtbase5-examples should contain a binary at
which spits out received mouse events.

Can you try that - especially with double clicking - and see what it outputs?


-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 898 bytes
Desc: OpenPGP digital signature
URL: <http://lists.x2go.org/pipermail/x2go-dev/attachments/20170811/c2b759e4/attachment-0001.sig>

More information about the x2go-dev mailing list