[X2Go-Dev] Bug#1200: Environment variables not set

Bruno CAPELETO bruno.capeleto at abcreseau.com
Thu Aug 10 12:24:20 CEST 2017

Package: <x2goserver>
Version: <>

# uname -a
Linux mtcie1 4.9.0-3-amd64 #1 SMP Debian 4.9.30-2+deb9u1 (2017-06-18)
x86_64 GNU/Linux

The below bugs are most probably related to each other, that's why I open
one case for all of them.

The issues are the following : I want to use the French software Laurux,
which is based on Gambas interpreter, via a x2go session running on a
Debian 9 server running LXDE (same issues seen on an Ubuntu server,
x2goserver version =

As a prerequisite, the software is installed on the server and runs well on
a local session.

1. Whatever the client (Windows or Linux, the local environment
variables are not set properly and the software - which needs French
localization - crashes. That could be "solved" the following way :
/etc/x2go/Xsession :

export LANG
export LC_ALL

That seems to be a revival of older bugs, but it is definitely still here.

2. At the start of a new session, one gets a windows with an error message
"No session for pid ..." ; that bug has already been reported several times
in x2go bug tracking and marked as solved. Actually it is not on my brand
new system.

3. The single application mode does not work with some of the applications,
including that Laurux / Gambas. For example it works with /usr/bin/leafpad,
but /usr/bin/libreoffice makes the x2go session crash.

4. The mouse double clic does not work in a x2go session, but only
- within the Gambas software (works well for example when launching an
application) and only
- when the x2go client is running in a Windows environment (no problem when
client in a Linux environment)

Many thanks in advance for any support,
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.x2go.org/pipermail/x2go-dev/attachments/20170810/487355f8/attachment.html>

More information about the x2go-dev mailing list